Jump to content

diesel spam


Giant
 Share

Recommended Posts

How many fuel filters does it have? Neighbour's worker turned up at home one time (his boss was away) seeking assistance with a stalled tractor. Turned out it had two fuel filters, one of which was near new and had clearly been replaced recently. The other one hadn't been touched and was clogged to buggery.

Link to comment
Share on other sites

  • Replies 400
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

10 hours ago, Yowzer said:

My experience with timing belts is they don't skip teeth, they strip teeth. Not saying it's impossible, but it seems highly unlikely. You have to have a lot of slop in the belt to jump a tooth out, which will mean a failed tensioner and you would hear the belt flapping all over the show. Easy to check though, the upper timing covers are easy to remove.

Pull the fuel filter off and see how much slime is in it. 

7 hours ago, Taistorm said:

Yeah I would probably look at fuel first, possibly not the issue but it's an easy place to start. Could be as easy as perished lines causing air leaks or possible blockages.

 

I've had many call outs from machinery not starting or running like a bag of shit due to them having fuel blockages in the tank.

it has 2 filters, one's an odd one i can't find a number on it, i did change the other. it pumped with the hand pump through the first unchanged one, i recall the previous owner saying that one (possibly a water trap?) almost never got changed in the 500,000kms 

 

5 hours ago, igor said:

How many fuel filters does it have? Neighbour's worker turned up at home one time (his boss was away) seeking assistance with a stalled tractor. Turned out it had two fuel filters, one of which was near new and had clearly been replaced recently. The other one hadn't been touched and was clogged to buggery.

6 hours ago, Mof said:

The tanks probably full of diesel bug blocking up the pickup/ strainer

Thanks for the reply, the tank has a drain bung, and i did drain off a few litres last year to check for water etc, it looked as new(does that algai/bug sit on the bottom or top?)


i'm not going to get to it real soon, but i appreciate the heads up. i'll keep you updated of what i find. 
i'll have to check the belt before i even move it to muck around with fuel filters or the fuel tank. 

Link to comment
Share on other sites

If the untouched filter is a water separator, I shudder to think what it looks like on the inside.

In my limited diesel experience consisting mainly of neglected farm machinery is this is one of the first places to look.
 

Link to comment
Share on other sites

1 hour ago, NickJ said:

If the untouched filter is a water separator, I shudder to think what it looks like on the inside.

In my limited diesel experience consisting mainly of neglected farm machinery is this is one of the first places to look.
 

it has a pet cock type drain on it, i've drained it somehow in the past to check it. not recently though. 

i found a pic i took when the wire for injector pump shorted out(rubbed through insulation near the bell housing so i hotwired it to get the van to auto elec(needed tow truck home due to 9pm at night in middle of nowhere)

AubQU2M.jpg

The fact it was kind of suddenly gutless was My concern, i had a bolt come loose inside the timing cover in My diesel gemini and it made the belt jump 2 teeth, i retimed it, and was lucky it didn't bend any valves.. replaced the belt and was good for 20,000kms + until i sold it recently. 
when that timing jumped it was gutless and extra smokey (one mechanic just said, mate.. needs a new engine.. suffice to say i went home and diagnosed it myself)

j2fs7vW.jpg

G1dZ2hy.jpg

ssGhpmu.jpg

 

 

Link to comment
Share on other sites

  • 2 weeks later...

So my kzj78 has shit the bed again

Stalled at work and wouldnt start. Plenty of fuel from the filter. But non at the injectors . Spill valve is brand new dense a few weeks ago. Has correct 1.6ohm resistance and the power to it hasnt changed from when I fitted it 

I cant smell burning electronics like I did when the old spill valve died. 

I'm at a loss. Maybe pump drive has broken?

Link to comment
Share on other sites

https://hiluxsurf.co.uk/forum/hilux-surf-forums-technical/-3-0-turbo-diesel/86611-1kz-te-starting-problem

End of page 1, start of page 2. Just a quick Google guess. 

^that's spill valve relay. 

Maybe also check the condition of the capacitors in the ecu, make sure none have leaked out onto the board.

Ecu is under the dash behind the glove box box. According to that link relay is in there too for a surf, probably the same.

  • Like 1
Link to comment
Share on other sites

Good thinking re the ecu, mine had several popped caps which had melted a few traces on the board.
Still ran but the trans wouldn't give 1st gear in drive and randomly drop out of overdrive, also went into limp mode at times.

Link to comment
Share on other sites

26 minutes ago, Mof said:

https://hiluxsurf.co.uk/forum/hilux-surf-forums-technical/-3-0-turbo-diesel/86611-1kz-te-starting-problem

End of page 1, start of page 2. Just a quick Google guess. 

^that's spill valve relay. 

Maybe also check the condition of the capacitors in the ecu, make sure none have leaked out onto the board.

Ecu is under the dash behind the glove box box. According to that link relay is in there too for a surf, probably the same.

Shouldn't be ecu. As @h4nd only recently replaced all the caps. 

I will check in the weekend though.

There was talk from one of the mechanics at work about a shared Input shaft on the pump. Maybe more common now they are aging

Spill valve is operating. I can feel it click if I hold it when they key is turned on.

If it's not ecu I'll be talking to Hayden at mds and might get them to diagnose it  

Getting over this sack and its unreliability recently aye 

  • Like 1
Link to comment
Share on other sites

I had a hilux in a few weeks back that stopped and wouldn't start again. The fuel gauge had stopped working and was stuck on half, but the tank was empty. 

Had just enough in the tank to make it seem like it had fuel when you prime it with a hose off

  • Like 1
Link to comment
Share on other sites

4 hours ago, JustHarry said:

Shouldn't be ecu. As @h4nd only recently replaced all the caps. 

I will check in the weekend though.

There was talk from one of the mechanics at work about a shared Input shaft on the pump. Maybe more common now they are aging

Spill valve is operating. I can feel it click if I hold it when they key is turned on.

If it's not ecu I'll be talking to Hayden at mds and might get them to diagnose it  

Getting over this sack and its unreliability recently aye 

The other one is here with a set of bodgy repairs, exclusive warranty! (excludes damned near everything). Will cost beer.

  • Like 1
Link to comment
Share on other sites

20 minutes ago, h4nd said:

The other one is here with a set of bodgy repairs, exclusive warranty! (excludes damned near everything). Will cost beer.

Yes, sometimes I remember about it. I'm almost never over your side of town 

Link to comment
Share on other sites

I'm still pretty unhappy.

Spill valve and relay are fine.

ECU appears fine 

Took the spill valve out and there is plenty of diesel being fed to it when I pump the filter pump

But nothing to the injectors?

Somone give me guidance before I just buy a mechanical pump from kaiapoi repowers :(

Link to comment
Share on other sites

13 minutes ago, JustHarry said:

I'm still pretty unhappy.

Spill valve and relay are fine.

ECU appears fine 

Took the spill valve out and there is plenty of diesel being fed to it when I pump the filter pump

But nothing to the injectors?

Somone give me guidance before I just buy a mechanical pump from kaiapoi repowers :(

https://www.trademe.co.nz/a/motors/cars/land-rover/listing/3355299264?bof=Mst7ExMe

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...