mikuni

Sheepers' RA28 Celica

Recommended Posts

yea, na.

none of the thermostats ive tested are even beginning to open at their stated temps. they all seem to be just cracking a few degrees above the stated temp.

  • Confused 1

Share this post


Link to post
Share on other sites

So maybe not an airlock problem, it should've worked it's way out to the cap or reservoir by now if it was do you think 

Share this post


Link to post
Share on other sites

is.. (I should click a few pages back)

it actually hot? Ie to the touch, or visiulay?

maybe ignore the meter / sensor? and roll as is

Share this post


Link to post
Share on other sites
Just now, JoKer said:

is.. (I should click a few pages back)

it actually hot? Ie to the touch, or visiulay?

maybe ignore the meter / sensor? and roll as is

Remember though, it shows normal temp when driving. 

  • Thanks 1

Share this post


Link to post
Share on other sites

Fuck yeah.. Progress. 

Was totally looking forward to you taking me for a drive in this at nats.. Next time hopefully... Definitely 

 

  • Like 2

Share this post


Link to post
Share on other sites

Been watching a bunch of engines getting built in YouTube. One guy had his water jackets half full of goo from what was probably old stop leak. Another had issues with a newish engine always running warm, full of casting sand still

Both discovered after knocking out the Welsh plugs and highpressuring it out.

Probably you hottanked your block or whatever tho

Share this post


Link to post
Share on other sites

Is the consensus that the max retard was the root of the temperature issues? 

Sounds rather glorious it's safe to say, you must be stoked.. 

  • Like 1

Share this post


Link to post
Share on other sites
Just now, sheepers said:

fuck man, i did like a million skids on the way home from the dyno.

 

 

Yeeee!

Share this post


Link to post
Share on other sites

hard to say exactly tbh.

temps did drop once we'd sorted the timing issue, but they were getting better all the time. the more load and running it saw the better it got.

so maybe a combo tight new motor and timing issue caused it?

i did learn that you cant use the trigger wire to the coil as the trigger for your timing light because it gives a false reading. i dont know by how much, couple of degrees i would imagine.

but it is false.

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
On 16/02/2020 at 20:31, cletus said:

How retarded is the timing? That can make things overheat  

 

Good old Clint.. 

 

Stoked it's going good.. 

 

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.