Jump to content

Gav's AWD Lancer


Recommended Posts

Got the engine off of the trans jack and removed the transfer case and then the auto.

20220528_145933.jpg.b7d89918dddb4b573f981fb181b7c9d1.jpg

20220528_160345.jpg.513ab5bbbe1deff4c1b2dada8bfaba7c.jpg

Waiting on prices for a rear main seal and cam cover gaskets.

 

In the mean time I had a look over the 'parts Lancer' the one with the Mivec 4g92. Which isn't running right.

When I test drove it before bringing it home it felt very sluggish. I wasn't too concerned since I didn't plan on using the whole engine.

20220529_142528.jpg.2596a05120078adfd624af9718799810.jpg

The heater fan controls and clock didn't work at all, I knew that the indicators didn't work as well.

Found FIVE blown fuses. That's a great sign...

20220529_143611.jpg.068d343d6bc8551cca5176528a2fc9fc.jpg

Replaced them and everything seems to work again. But why did they blow? I did find that the stereo loom has been cut and is exposed, but would think that would only blow one fuse.

Exhaust is leaking, found gasket very buggered, kind of looks like it was installed wrong too, like it was jammed in since the sides are bent up.

20220528_141142.jpg.0b1765b85fd85e496389854e9273310b.jpg

 

Yes those floor mats are amazing.

As a temporary measure to shut it up I put on some exhaust gasket goo and left it overnight. 

Started it the next day and found it was another loud leak from the flexi. I want to drive it around the block to test it a bit, so wrapped it in some fiberglass matting and held it on with some hose clamps :lol:

Sounded a lot quieter so got it to operating temp and took it around the block.

VERY sluggish. Like the timing is retarded?

No misfires and revs fine, just very very sluggish.

In first gear up I got it into the MIVEC engagement point which is something around 5000rpm. It really opens up and sounds really cool. But still super slow.

So at least I know the Mivec solenoid is working and it must have enough oil pressure to engage it.

I got it home and pulled a spark plug, looks real old. Was about to do a compression test but then my wife got a bloody migraine. So dropped it all and will get back to it another day.

 

I am semi considering putting the 1.6 mivec into the awd Lancer. Since this parts car Lancer appears to have been driving around for 12 years with this conversion... it's a lot of effort though when the end goal is to build it with a 1.8 block and turbo it. But then again the first wof could tell me to go away and cert it.

 

  • Like 7
Link to comment
Share on other sites

Got the torque converter off and had a look at the rear main seal.

It was practically falling out, this is how it was, already half out.

20220602_161518.thumb.jpg.49f7c8272ef6c229adc9417582631d6b.jpg

I didn't even need to pry it out just touched it with my finger tip and it flopped out...

20220602_161527.thumb.jpg.56e8d2e435c54cb5f98d0764e18b5821.jpg

 

It can just be slid back in with zero effort.

Something about a hallway and a hotdog.

Do these seals shrink?

Waiting on BNT for some seals but Covid has done a number on them. 

 

 

  • Like 1
Link to comment
Share on other sites

Also tried to do a compression test last night, number 1 went up to about 200psi, but I think the one way valve in my tester is stuffed because it just drops to zero again. Didn't have this problem a week or two ago.

Then tested number 3, because 2 and 4 have the coils in the way and it was raining by then.

Same story, about 200psi and drops to zero as soon as I stop cranking. Annoying, wonder if I can fix the tester...

Thought maybe there was a check engine light that I didn't notice that could explain the sluggishness. Nope, light comes on then goes off after it is started. Seems to idle and rev perfectly smoothly.

Check if knock sensor wire was still attached, it is, would think there would be a constant check engine light if something like that was wrong. i.e. limp mode type thing.

Another guess would be that there is ECU damage from what ever caused 5 fuses to blow. But the fact it seems to start and drive fine with no check engine light it doesn't really fit.

Maybe the timing is out?

Also the ECU is hanging down in the passenger foot well. As if it has recently been worked on. There is also another ECU that was just in the glovebox, it looks to be for a non-mivec Mitsi (plugs simply not compatible).

I THINK the engine swap was done in 2010 because that matches with the Mivec cluster on carjam. i.e. the km's drop significantly to match what this cluster would have had on it back then. It looks to have done 40,000km's since then too so surely it didn't have the ECU just floating around like that.

Car jam history shows it changed owners a bunch of times in the last year. It didn't worry me when I bought it because I wanted it for parts. So I think a lot of people gave up on fixing what ever the problem is.

 

It would be nice to know what is wrong with it, but I guess I am not going to be using this ECU or even short block. So I will probably stop trying to diagnose it and just get the engine out in order to swap in the 'correct' 4g15 from the 4wd lancer.

That way I can tidy it up, hopefully wof it without too much issue then sell it. I'll grab some clean trim from Pick a Part and that'll make the interior nice, it's actually pretty good apart from the crappy silver spray paint.

 

I wish I had more time to get through these projects, I really enjoy diving into each one and making them good again...just not enough time to do it all.

  • Like 3
Link to comment
Share on other sites

Coolent temp sensor, ecu retarding timing until it comes up to operating temp, can always test the sensor and or just unplug to verify

If the temp is no good it wont know its warmed up :P

Link to comment
Share on other sites

15 hours ago, shrike said:

Coolent temp sensor, ecu retarding timing until it comes up to operating temp, can always test the sensor and or just unplug to verify

If the temp is no good it wont know its warmed up :P

Yeah good idea could be that. It was up to temp on the gauge, although it probably has a separate temp sensor for the ecu.

  • Like 3
Link to comment
Share on other sites

On 03/06/2022 at 19:16, shrike said:

Coolent temp sensor, ecu retarding timing until it comes up to operating temp, can always test the sensor and or just unplug to verify

If the temp is no good it wont know its warmed up :P

Tested the resistance of the water temp sensors from the mivec parts car and compared it to the one of the spare head I bought earlier in the thread.

Both react to hot and cold water the same, both have the same resistance at room temp.

So I think they are ok.

This water temp sensor is in the back of the head rather than the one that is in the thermostat housing, which is definitely for the water temp gauge. So I assume this other one has to be for the ECU water temp.

It was worth a try though, could still be related. Maybe the wiring is damaged etc.

  • Like 1
Link to comment
Share on other sites

Doing more work on the parts car than the 4wd one!

Had a good clutch and the correct flywheel for the 4g15 so cleaned those up and installed.

image.thumb.jpeg.d6c8ca78b40a8e7ce2c45f6b765b9e8f.jpeg

Put the parts car up on the hoist and started removing bits.

image.thumb.jpeg.944fc86c2be570971c7de91761cec7ba.jpeg

 

It's a bit rough but it'll be a good car when done.

Here is my temporary way of shutting up the exhaust leak for the test drive of the engine that is coming out of this lancer.

Fibreglass sheet, aluminium tape and some hose clamps. Worked pretty well lol.

image.thumb.jpeg.7fc527f8178c1cf2179c244acd40a102.jpeg

 

Have drained the gearbox, engine oil and radiator.

Removed front wheels, found a snapped stud, loosened driveshaft nuts.

 

Quite like the colour too. Don't like the wheels though.

  • Like 2
  • Haha 1
Link to comment
Share on other sites

Oh and before putting it on the hoist I checked the ign timing, I couldn't find anything about having to bridge any pins or anything in order to check the base timing. But checked it anyway and it's consistently in the same spot on the timing cover mark but didn't go any further than that. It's all coming out and changing anyway.

It idled fine but when I went to move it, it would almost die under a little bit of throttle. Like it was running out of fuel (it did the night before I bought it, so I'd put in 4-5L to test drive it at the time). 

So I put in some more fuel but it made no difference. Coughing and spluttering.

Maybe the fuel filter is clogged?

I'll check it when I take it all out.

  • Like 1
Link to comment
Share on other sites

Took the manual fwd gbox off of the mivec engine.

 image.thumb.jpeg.cbd48ab37ee776f933148b05858b701d.jpeg

 

Cleaned it up, didn't take a photo so just imagine it has less dirt.

image.thumb.jpeg.991c3eecca784dcca0e263063c63b3bc.jpeg

 

Put the gbox onto on the 4g15 and confirmed that the bellhousing bolt pattern is the same which is good.

image.thumb.jpeg.f605670d24d34437e3297425145a16d9.jpeg

 

Also welded up a crack in the lower radiator support, just looks like someone positioned a jack in the wrong spot. Fixed now and painted.

Think there might be a difference in the power steering pumps because the crank pulleys are different between the engines. Hopefully I can mix and match something to work.

Mainly an issue because the mivec engine has a non-A/C type bracket for the P/S pump, which includes a idler pulley to tension the belt where the A/C would be. But the crank pulley on the 4g15 might stick out further. Guess I'll see.

 

 

 

 

  • Like 5
Link to comment
Share on other sites

  • 2 weeks later...

My 200sx 1jz car lost compression on the dyno last week so needed to get the 'parts lancer' off the hoist, so put the 4g15 in and got it rolling again. 

 

This combination of transmission jack (500kg rated) to position and lift the engine up in stages plus the hoist to lower the car over it works pretty well.

 image.thumb.jpeg.c387959c7737f78c63e970fb5e6dd9ed.jpeg

 

It's in:

 

image.thumb.jpeg.e6894d131b4a1c1573d65dfda3552588.jpeg

 

Wiring is a bit different but have got it turning over at least and confirmed the clutch is all working. Will look at the rest later.

 

Found some amazing twist and tape wiring in a few places:

image.thumb.jpeg.53f96b7ec0cc38dccbbb08c4544a9e95.jpeg

 

Also here is the fuel filter cut open, this is the one which I suspected might be causing fuel starvation on the mivec/parts car.

Doesn't look great but not really as bad as I was expecting. Could still be blocked with tiny particles.

image.thumb.jpeg.609e471454c4e715f30522b2387a1a72.jpeg

 

Have now moved it out of the garage since the wiring doesn't require it to be on the hoist.

 

  • Like 5
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...