Jump to content

How to Wire up a 1UZ engine (VVTI and non-VVTI)


Recommended Posts

hello friends,

am new here. saw your beautiful and detailed information about the wiring diagrams of 1uzfe. i became a fan of you.

i had brought a half cut of 1998 model lexus ls400 with 1uz vvti engine. when i brought it the guy started the engine and gave me. i took the engine and fixed it in a 89 rps13 nissan silvia. bloddy hell, the engine starts and then switches off. i tried my best and couldn't start. i fixed the engine back in the half cut and took it back to the guys and they started the engine again and i was shocked. i took the half cut back to workshop and they also started the engine on the halfcut. when fixing it back it din start. again starting and the engine goes off. then one of my friend said problem is in the wiring. i have to fix the original lexus key holder and many things to start the car and to get the gear to shift. i have no clue as to how to do it. can you pls help me out of my misery?

regards

nabeel

Link to post
Share on other sites
  • Replies 157
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

i know about aftermarket ecu's. i do wiring and tunning of most of them ( motec, haltech, microtech, autronic etc...) i work for a garage where we modify engines, turbo or super charge them. so the wiring was done by me. here one guy said he will do it without using the key of the half cut. but his fees was like wiring a new aftermarket ecu. so i din want to continue with him and looked for your help.

so i will have to use the original key and stuff's with the ecu ???? there is no other way around?

  • Like 1
Link to post
Share on other sites
there is no need to do that, earth in the ecu comes from it's specific earth wires. no reason not too, but nothing in the case connects to casing for an earth.

it does need to be a good earth, and you must have more than 11 volts, and decent amperage to run it, so if your trying something funky with some AA batteries it wont be enough (btw).

Hi Nigel

Yes, i was using 55A car battery, so far i have no issue with it.

So my ecu was align with your wiring diagram right? pin by pin

Best Regards

Btw Here is my wiring to the ecu, please correct me if im wrong.

ls4001wiring.jpg

Uploaded with ImageShack.us

Link to post
Share on other sites
Looking at your diagram I'd say MREL is probably not working (if I remember your issue with the check light), if I remember correctly that doesnt actually turn the efi relay on, but I've noted in the write up that it does and I havent changed that so it probably does.

[edit] nah, it does, I just checked on a 1992 ecu, and it turns it on a relay just fine, but it's an output so it might not turn a light on well though.

- MREL is an ecu output that comes on when the engine is being started, and also comes on for a split second when turned on, thats a bad source of power for the check engine light it wont behave in the right way, you need constant stage two power

- but thats just from memory, I did look over the lextreme diagram and my own work and it appears like that could be causing the issue.

- you dont need to fuse the check engine light.

hope thats helpful :)

Hi Nigel

Thanks for the update,

My setup for MREL is to trigger EFI Relay which turn ON the connection between +12V to B+

Based on your update , heres what i am going to do

Give +12V directly to B+,

And well see what happened

Best Regards

Link to post
Share on other sites
yeah, b+ should be constant mate, fused as best practise but not necessary as ecu has a thermal fuse on it's main board for it anyway.

Hi Nigel,

Thanks for everything, i can confirm the check engine now is on.

Next step is to try starting the engine :)

Thank You Million Times

Regards

1uzcheckengine.jpg

Uploaded with ImageShack.us

Link to post
Share on other sites
  • 1 month later...

Hi Nigel

It’s been a while since my last update, so far here what I have been done

1. Trim the wiring

2. Removed unnecessary wires and sensor (2nd TPS, Traction control motor,)

Rewiring these to ECU

1. All 8 injectors

2. Water Temperature sensor

3. Airflow meter

4. Crankcase position sensor

5. Camshaft position sensor (2 of them)

6. Igniters

7. TPS

8. ISC

9. Engine speed sensor

10. ?

Is there anything that I miss ?, assuming i dont run the auto at the moment

Btw hong long does an engine can survice running without radiator?

Regards

Link to post
Share on other sites

Hi Nigel

Thanks for the reply, Yes i forget to mention knock sensor under the plenum.

About the 02 sensor, is it possible to bypass without making ecu using default/base map?

Because my engine got only 2 sensor left, each 1 in the exhaust manifold.

I do agree with you regarding the radiator, i will put the radiator then.

Regards

Link to post
Share on other sites
Hi Nigel

About the 02 sensor, is it possible to bypass without making ecu using default/base map?

Because my engine got only 2 sensor left, each 1 in the exhaust manifold.

hang on a sec, you have two that you want to bypass ? (in which case no). you can run the engine just fine without o2's, as a test. or even on the road, but you _NEED_ them for fuel consumption, power, and good running.

Or you have two, your ecu has the cable for four of them, and you want to bypass the sub o2's,

yep: you can do that it's real easy. read the second part of this link (where it mentions four o2's).

http://www.oldschool.co.nz/phpbb/viewto ... 28#p727866

Link to post
Share on other sites

wow i am impressed i have been following this post and have read every word . i have followed the wiring ( system ) and tested mine last nite and bugger me only two codes ( 31 and 56 so not a bad start . so i thank you for your great right up . and if any one is in timaru and is in the shit i would be happy to help out . i am a diesel mechanic but am fast learning the toyota petrol systems (i know a guy that had a 1uzfe engine job done locally and i heard through the grape vine it cost the guy 17G bugger that

Link to post
Share on other sites

i think some of the wiring descriptions could have a bit more info on them thinks like < the trans eco/power switch the nsw switch ( what i have found is that most are now running with the lexus trans ) i was lucky and brought a complete uncut engine and gearbox . but it would be great to find the diagram for those three body plugs anyway i am just rambling on about small things (i tend to over think wiring jobs ) what part of the country do you live in i am in timaru

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...