Tumeke

Tumeke's 2.5 PI Trumpet

7 posts in this topic

Pulled some stuffs off on the weekend to have a wee look at timing and other such things.

3vly3yhd.nsd.jpg

Something wasn't quite right when checking the timing of the fuel metering unit (to manual specifications) so pulled the dizzy out and found things to be off from where should be

agxbzsd2.c1c.jpg

Fudged stuff about for a long period of time and made the dizzy dog line up to 12 o'clock and the metering unit injector # 6 position to be within the satisfactory limit, and the dizzy rotor to be at number 1 lead for timing at TDC compression stroke.

Then flushed through injectors again, all worked (some a bit temperamental but ok with a good smack)

Then managed to started car. It did kinda start with a bit of ether up it, but not running properly. Rotated the dizzy and got it to stay running. Feels like the timing marks on the pulley are wrong..?  Didn't have a timing light to check any further into that. Got it running on 4-5 of a possible 6. Still, progress I think.

Tonight I'll try to put a timing light on it, replace a couple of injectors with more reliable spares and see what happens then.

You, too can tell me how the TC is much more reliable, like everyone at the European British car show, by clicking here.

 

 

3 people like this

Share this post


Link to post
Share on other sites

Went back last night. Something is not right....

New theory - anyone had this kinda thing below happen? 

damper-refurshbiment-fig-5-large.jpg

(Interweb pic - not mine) or has the key just fallen out / shattered?

Discuss!

 

 

1 person likes this

Share this post


Link to post
Share on other sites

Lil more progress however she's running oh-so-rich - to the point that I keep fowling plugs / black smokes.

Been through a few plugs now trying to diagnose. I reset the max fuel screw to factory spec on the metering unit and fluffed about with trying to balance the throttle bodies. These could do with a bit more work, but I don't think they are out enough to cause this kind of enrichment. Also, overfuel/choke lever is resetting per guidelines. Blew the over-fuel return clear with the compressor, and then checked for vacuum pressure to metering unit  - which seemed a bit low - however I might have also fowled a plug in this process. Did a compression check and all around the 160 mark which I would consider healthy. 

Did a dort sans bonnet up the road

So, next steps (and yes - please comment/suggest) are : Double check ignition side -  try another coil in case it's weak, replace/clean plugs again, test lead resistance,.

Vacuum to Metering Unit: more vacuum diagnosis across all three sets to see if any difference with side of metering unit to check travel. 

Metering Unit: Double check fuel pressure with another gauge, then if that all turns pull metering unit again, replace all seals / rebuild and/or start playing with calibration adjustments under top cone of metering unit. (I don't want to do this.... see below) Also - all o-rings at both injector end and metering unit end could also play into problems.

Metering-Unit-expl.-UK.jpg

 

3 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now