Jump to content

Search the Community

Showing results for tags 'crown'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Technical
    • Tech Talk
    • Tech Articles
  • Projects
    • Projects and Build Ups
    • Project Discussion
    • Two Wheels
    • Other Projects
  • Oldschool Happenings
    • Upcoming OS Events
    • Upper North Island Region
    • Lower North Island Region
    • South Island Region
    • International/Australia

Categories

There are no results to display.

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Skype


Interests

Found 4 results

  1. Discussion thread First build thread so am still working out website. Hope everyone enjoys and feel free to add comments as am still learning so much about these crowns. Earlier in the year I had purchased my first toyota crown. I've been a long time toyota fan building them and playing with them since I was 16 (8 years ago). I brought it off a fella in Christchurch and coincidentally had a week off work at the time. So I spent the next week getting the thing a wof as it hadn't had one in 10 years. Its a mettalic blue Ms83 crown wagon. Rough around the edges but it ran, it dr
  2. yeah g'day. so i spun a yarn at work saying i needed a wagon and something to move me furniture and go camping with. along came a chap with a friend who had 'this old wagon chilling at his place'. One thing led to another and i was dragging this old Crown wagon out of a tree. It's been sitting for 3 years, hasn't been turned on and is pretty well dormant. I chucked a fresh battery into it and she ticked over first try. Won't idle but i'm open to theories as to what would cause that - seems a bit trial and error at this stage. Will need a few parts here and there, but as it's a Crown,
  3. Took my 1995 130 Crown wagon up to Auckland handles way better with new shocks; but the factory non-VVTI 2.5 n/a 1j is slow as shit... The wagons too heavy for it. I'm keen on the idea of throwing a 2jzge in there; the 3.0 will make the wagon get along a lot nicer and turn it into a nice cruiser. And Don't want to go down the 2jzgte track, So there's a low km non VVTI 2j n/a on TM for sale for $2500 from a JZZ31 94 soarer... Or 1500 without ancillaries... Questions I have is: 1) will the 1j ancillaries bolt onto the 2j? 2)will the 1j ECU run the 2j? 3) do I need a cert for the
  4. One of my long term projects, 1980 toyota crown. brought it after it sat up the end of the brook valley after the old couple parked it up when it hit 400,000 ks gave them $200 and i was away. towed it home, some new fuel, plugs and a dizzy cap and it fired up pretty good. unfortunaley has the common rear quarter rust. pretty bad, someones patched it up before and made an average job. plan is to get it legal (can't see it needing much bar the rust) and just drive it, eventually lower it
×
×
  • Create New...