kurt.

Members
  • Content Count

    77
  • Joined

  • Last visited

Community Reputation

65 Excellent

About kurt.

  • Rank
    Advanced Member
  • Birthday 15/07/1993

Recent Profile Visitors

401 profile views
  1. altanator seems iffy. Goes flat if I don't drive every couple of days.but that could also be battery. Is the second alt I've tried. I tried another head unit today(first time in months) and it's doing something I forgot about. When you take the volume down to 0 or change radio station, it makes the sub do a big pop. Quite loud. Does that help at all? Cheers for all the help though guys!
  2. Hey, thanks for all the helpful replys so far. First I'm running an external amp, pretty sure I've tried removing that and running speakers straight off headunit. Same problem. I've tried a few different head units. A new Bluetooth etc one is a lot worse than my old one that only does cd and radio It's a rb25det so is running cool on plug I believe? My old man suggested suppressors the other day, that's what got me thinking about this problem again. I've played around with a million earths. Headunit to Rca cable new earth on block on alt on battery, Battery is in the boot so Rca and power supply aren't together.
  3. Hey guys, just after some advice. This has been driving me crazy. My headunit picks up alt whine. The higher the revs the higher pitch. I've tried Different alt Playing around with founds on alt headunit amp amd battery, I've tried grounding my headunit to my rca I've been to an audio shop and they had no idea, said they could try a lot of things but would be trial and error Whine gets a lot worse when I also charge my phone in cigarette lighter. I'm sick of driving around with a Bluetooth speaker. Please help Car is a 1990 skyline r32