Jump to content

Maxteds 1969 mazda B1500


maxted
 Share

Recommended Posts

the sump and pick up fit on nicely, hopefully gives me enough clearance I may have to take a small chunk out of it to clear. also have stripped the engine down and painted the block and given it a good clean.

got the rocker cover from the b6t engine dipped and bead blasted and then gave it a lick of paint. plan to pull everything off the intake manifold to clean it up and paint it either silver/Aluminium. 

post-9567-0-11947300-1464863557_thumb.jpg

next job is to pull out the ma engine and box, then sort out the mx5 bellhousing onto the 626 box to get it ready to drop it in so can make it some mounts

Link to comment
Share on other sites

  • Replies 98
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

post-9567-0-40547700-1465380639_thumb.jpg

motors starting to look the part, new water pump and timing belt kit, ditched the belt covers. need to finish cleaning and painting the rest of the brackets/pulleys/inlet and alternator ect, also need to work out how to mount the coils on new rocker cover. hopefully pull out the old motor this weekend

  • Like 6
Link to comment
Share on other sites

  • 5 months later...

well its been awhile, this has taken another 180 degree in direction with new plan to stick with the original donk to avoid certification and keep costs down, so pulled down the original 1600 NA to find the reason it smoked so bad, found all the 2nd and oil control rings gummed up and stuck in the grooves , but the rest of the motor looks really good so its getting a freshen up and going back in. so pulled the MA that was in there out ready for the 1600, managed to track down some new rings and a timing chain kit, hopefully get it back together this week and get it going sometime next week 

post-9567-0-86075600-1479722075_thumb.jpg

 

  • Like 5
Link to comment
Share on other sites

  • 3 weeks later...
  • 4 weeks later...

been trying to do a few little jobs on this after driving it for a few weeks, these bloody door latches are shit and slogged out with lots of play up and down and side to side so you have to dam near slam them to get it to latch, so i have dragged out my spare doors and pulled the units out of them and i was pretty stoked to find the passenger side is tight as and the drivers has minimal so might chuck them in and hopefully can adjust them up nicely now the rubbers are starting to find their shape. 

IMG_2730.JPGIMG_2731.JPG

IMG_2728.JPG

IMG_2725.JPGIMG_2726.JPG

also I made a cradle for the stereo and mounted it under the glove box, just need to run the wiring for the speakers and finish making the new door cards to mount the speakers and get them recovered hopefully in a similar red to the seat and then get the new kick panels cover in black.

IMG_2729.JPG

IMG_2727.JPG

have mounted twin gauges under the dash for extra piece of mind on oil pressure and water temp, i wanted to keep the dash oil light and water temp so dragged out spare thermostat housing and oil filter housing and have had them drilled to fit the new gauge fittings leaving the original sensors in place, when i dump the water to put some antifreeze in and dump the oil now the engines done a few kilometres ill swap the housings over.

IMG_2732.JPG

 

really need to get the new steering column bush in, I'm getting sick of the rattle!

 

  • Like 3
Link to comment
Share on other sites

no more rattle! was such a bitch to get the alloy bush someone had made out, that i had to remove the steering column out and slide a pipe inside to bash it out. now i can get the hole for the column change filled in on the steering surround and install it.

IMG_2738.JPG

Link to comment
Share on other sites

  • 3 weeks later...

FullSizeRender.jpg

this happened!! pretty gutting as i can't find the same tyre anywhere so i am waiting on a pair of tyres with (hopefully) a similar thickness whitewall. o well at least the spare will now be a near new tread tyre.

the tapped thermostat housing was a fail the temp sender just fouled the thermostat so brought a junction to go in radiator hose instead.

has been pretty good being daily driven goes really well for what it is, the speedo cable has decided to play up unsure whats going on with it might just try another if i can find one 

  • Like 2
Link to comment
Share on other sites

  • 1 year later...

Well its been awhile since parked this up. going home for Christmas, looking forward to dragging this out and finishing off some of the odd jobs left to do on it. also managed to find a full set of NOS mazda chrome hubcaps have been keeping an eye out for a set of these for such a long time pretty stoked to have found some. hoping to tidy up the interior when get back, re-cover the door cards and dash and maybe clean or paint the hood lining or replace it. also want to weld up the hole someone cut to put a head unit in the dash and then put the original stereo blank back in.

2006720447_ScreenShot2018-11-19at11_26.01copy.png.79a94f740694484136fbed40ea42ae88.png

  • Like 6
Link to comment
Share on other sites

  • 4 months later...
  • 7 months later...
  • 3 weeks later...

finally stripped out this courier, had a lot of things I needed on it so was pretty stoked.

going to get some little welding jobs done on the floors to sort out some pin holes and patch where someone has butchered the radio hole in the dash and holes someone cut in the inner guards, then hopefully swap out the gearbox and driveshaft and try get rid of an annoying vibration it seems to get at approx 50-60kph.

 

IMG_3113.jpg

IMG_3115.jpg

IMG_3118.jpg

  • Like 8
  • Sad 1
Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
  • 2 weeks later...

Lick of paint for the gearbox before it goes back together with new bearings. hopefully be a lot quieter than the one in there. cleaned up and painted the 4.3 ratio nugget from the courier I stripped, fingers crossed it drops the revs a little bit I think it has something like a 4.8 from the factory in it.

IMG_0625.JPG

  • Like 4
Link to comment
Share on other sites

Also cleaned up the round port manifold, trying out some por15 manifold paint this time the VHT flameproof is flaking off the last manifold I painted (maybe I didn't prep it well enough I can't remember), after looking in the engine bay I think the pipes coming out the side are going to foul the engine mount so might need to cut them short and plug weld them 

IMG_0623.JPG

  • Like 6
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...