Sign in to follow this  
jakesae101

Jakesae101s 1985 mazda 323 rally car

Recommended Posts

So after a few years away from any motorsport I went and volunteered for targa to do timing again for them with a bunch of mates i got the bug again i had eyed this up as it was so cheap anyway. I convinced my other half that there was no way could I finish my trueno for what this cost so that will be going even further on the back burner 

 

now after a lengthy chat with the seller the deal was done it has a bit of rust to contend with but none of it overly serious reg is on hold did its last event rally of gisbourne in 2011 then the guy had a kid and he didnt race again

 

engine is a 1500 single cam engine, dual carb, has had mild cam work, mild porting, polished port, the pistons are one oversized and has been balanced. It is a standard gear box Has a terratrip. Has a full manz roll cage. Comes with it's log book it needs new belts but im fairly sure the ones in my trueno are still in date / they are cheap anyway 

 

 

so he said for a extra 100$ hed bring it to napier for me to halve my drive to go get it. I pick it up the first weekend of december as im away again in a couple of weeks so I cant wait plan is ill tackle the rust and give it a clean up on my break over xmas 

 

 

oh and look at that sweet momo steering wheel that really sealed the deal

 

mazda4_zps6a1jhwgl.jpg

mazda2_zpsg7em4wyn.jpg

mazda11_zpssdxilnvh.jpg

mazda3_zpsx2eovgwo.jpg

mazda5_zpsu4rbctq0.jpg

mazda6_zps2iblsmmq.jpg

mazda7_zpsihfg0opy.jpg

mazda9_zpsxznow5cr.jpg

  • Like 8

Share this post


Link to post
Share on other sites

pictureless update for now 

 

Well its home set off from my place at 7 am to pick up my mate then went and got a trailer from a friend we got into napier at around 1230 and loaded the car on in 30+deg heat and set back home . the roof rust is definitely worse than expected i think its had repairs done to its previously  and the small patch of rust on the floor is actually a hole but other than that its not bad . Has had an electric fuel pump ect installed and it seemed to go pretty well and was making all the right noises when i took it for a hoon round the block the carbs need a bit of a clean i think and the brakes are a bit spongy from sitting around 

 

so picked up a new(er) mig and will get some steel the best bet would be to find another roof and get it put on by a panelbeater but parts are pretty few and far between so for now im just going to start patching the rust and priming it. I will get a panel beater to spray it so stand by for some terrible body work i haven't done too much of it before but we all have to start somewhere right?

 

ill chuck some photos up in the next few days 

  • Like 2

Share this post


Link to post
Share on other sites

so im off work till the 5th so trying to get some done in between family time at xmas

 

its quite a bit rustier than i thaught the inner skins are rusty also so im rest neutralizing and sealing what i can theres a bit of filler and there will be more filler going in its not huge amounts and its far better than what i cut out its all been repaired before with just filler in some places some bits have been badly patched with filler on the bare steel 

 

im really shit at taking photos as i just get into it and dont think about it much i got some done on xmas eve after work and some done today after it had cooled off a bit and the car was in the shade as its a scorcher here today 

 

so these were the patches i did on xmas eve

 

image_zpsrk0vbqme.jpeg

image_zpsimtg7syh.jpeg

 

 

today i wanted to see what was under the bog between those 2 patches no clues on the outside but it was pretty grot underneath

 

cue this

image_zpsbrb37qow.jpeg

 

 slowly getting a bit better at it i think one day ill be as good as sheepers and azzuro maybe that patch extends to the gutter aswell as that was all rotten there too 

 

all primed up

image_zpsfmxssees.jpeg

 

my sweet welding setup 

image_zpsgt4ppvpe.jpeg

 

i got some new tinsnips also this made everything much easier 

image_zpszdh3kuqh.jpeg

 

and lastly the rest of that side is pretty chooched so going to cut it out in one big strip and weld a new bit in im really hoping the other side isnt as bad and i just have to patch the floor 

image_zpsunzxlzmq.jpeg

 

i hope to get the other side done next week and the floor then fill it and prime unsure what im going to do re painting it was thinking i might just wrap it or something 

  • Like 1

Share this post


Link to post
Share on other sites

right so all the known rust is now done filled and reprimed its not perfect but its close enough it was never going to be a masterpiece but it should see me though a few years of racing

 

image_zpsqmrd5zgz.jpeg

image_zpsnlxpfips.jpeg

 

we noticed that there was lots of little surface rust spots on the floor so i decided to repaint it

 

image_zps86bwa9zw.jpeg

 

with a little help from my co driver my fiance

 

image_zpsxcfpde7w.jpeg

 

image_zpshckixqhy.jpeg

 

we also removed all the rollcage padding as it was perished  , We also gave it a wash chucked some fresh fuel into it and it ran way way better its idling super high so will have a look for a vac leak and start with the easy stuff and go from there need to finish painting the floor and do some undersealing over the next few days and have a look at the brakes and take it for a run round the block 

 

image_zpscpbzhng7.jpeg 

  • Like 3

Share this post


Link to post
Share on other sites

so its been an interesting few days and it did not end well

 

so the floor started off like this 

 

image_zps86bwa9zw.jpeg

 

in the end we got it looking pretty dam good with a coat of Porirua pearl as they guy at supercheap put it or matty b to everyone else 

 

image_zpsobtuepag.jpeg

image_zpsxeqeifse.jpeg

image_zps50y6p4dl.jpeg

image_zpscocchiwp.jpeg

 

then i also found out that all the rubber fuel lines were perished so i replaced those and added a filter in so after that i started it up and re tightened a few things now the car doesn't idle too well cold as its had the chokes removed from the carbs and it stuttered out at idle and as finally died out i heard a clunk and i couldn't start it again 

 

so got a spanner on the crank pulley and could move it backwards and forwards but only slightly so i decided to take the cam cover off i was greeted with this 

 

image_zpspd7gaq5s.jpeg

 

the link closest in the photo failed and the pin came out all i can think of is the tensioner was shit or the chain was worn and it whipped round as it was dying out at idle and had enough luckly its a non interference engine and the parts were a total of $60.99 on clearance

 

image_zps7ralzddt.jpeg

 

complete new old stock timing kit with the oil seals , gaskets , tensioner and tensioner arms and 2 new chains one for the oil pump and one for the camshaft

 

originally i was keen to do it myself but it being at home i dont have all the access to the tools i need and i cant get the crank nut off so i might just flat tow it to the garage down the road and pay them to do it unless and oser is keen to do it round the jvlle tawa porirua area   

 

guess id rather have this happen at the beginning at under idle speed stationary rather than at full noise racing and i know it will be good for quite some time 

  • Like 1

Share this post


Link to post
Share on other sites

Well today it went on the tow truck to a guy who is a member of and does a bit of work for the people in harbour capital car club of which i am a member of also. Hopefully I will get it back later this week as long as there is no other damage when its all taken apart stand by for pictures hopefully he will take some for me

Share this post


Link to post
Share on other sites

ITS ALIVE !!!!!

 

was the txt i got yesterday and today it showed up on the tow truck again at my house 

 

heres a small video for proof

 

https://www.youtube.com/embed/AKZFtz2UEsY

 

so i took it for a burn round the block and it runs like a champ only issue now is its distinct lack of brakes so will have to investigate that one they are a bit spongy so will get some new fluid and bleed them up and see what happens and whip the drums off the rear to check for any leaks 

 

oh and i got the terratrip to work there's a hidden switch in the glovebox so will tidy that up and put it in the dash 

image_zpswqnux7u6.jpeg

 

i also got a graytronics intercom pretty cheap and have the parts to make some leads up for it an it uses all the terraphone accessories 

image_zpsvutb2twq.jpeg

 

oh and i spotted on trademe 2x momo seats for 40$ each they will work with my current rails i just need too make up some 15mm spacer for the rear bolt holes im not sure what im going to do there yet 

12626203_10153191854756890_581711693_n_z

12620729_10153191854711890_1270079670_o_

 

and giving them the sit test in the driveway the old autosports were comfy as but lack the hole in the base for the crotch straps 

 

12631313_10153192103076890_5585367072231

  • Like 1

Share this post


Link to post
Share on other sites

so ive been cracking on with a few jobs over the long weekend all the really big jobs are done pretty much just lots of little ones 

 

i got a new battery box to replace the smashed one and re jigged the bracket that the old owner had cut in half and made it fit the new battery he put in 

 

image_zpsjxxjww8i.jpeg

 

not pretty but functional and strong and meets manz specs 

 

image_zpsjsxzizep.jpeg

 

looks much better with the lid on

 

i also installed the new seats the blue one was easy the seat holes were correctly spaced for me to just bolt the factory rails on by just drilling 2 new holes the red one is narrower and i had to cut the rear adapter plate and it bolted on and i used new high tensile bolts they look much better and semi match the steering wheel now

 

image_zpschr2nttl.jpeg

 

I had some autometer gauges sitting round so i got a water temp one in a smaller size so they could all fit in the panel that had a old oil pressure gauge in it and yes i know they aren't straight they are like that so in their normal range they are pretty much all straight up 

 

image_zpsh5ozaneo.jpeg

 

just waiting on a 1/4 npt to 1/8 npt adapter for the water temp gauge and they will all be functioning this is all for now  

  • Like 1

Share this post


Link to post
Share on other sites

so the brakes had never been fantastic and by that i mean shit so first port of call was to bleed the brakes as the car had been standing for 5 years got a bit of air out and rid of this skanky fluid it actually stops now 

12714092_10153214844606890_975722319_n_z

 

this morning i did a job id been putting off for a while the main part of the floor and boot floor had a bit of surface rust and it was down to the primer so i took off all the loose stuff and rust killed it then gave it a coat or 2 of truck bed liner came out really well considering 

 

12746112_10153215976336890_241348892_n_z

 

12714257_10153215976211890_1626240820_n_

 

the rest of the floor pan is ok and i rust killed any spots i think needed it should hopefully last a while 

  • Like 2

Share this post


Link to post
Share on other sites

wow a month not too much progress really to speak of got a few jobs done 

 

got a new soldering iorn and made up my intercom leads

image_zpsbeot7akz.jpeg

 

 

I finally got the adapter I was waiting for a few weeks ago and found i had misread the thread size so a mate drilled and tapped the adapter for me so i pulled the rad out gave everything a flush with the hose cut the hose. put the adapter in and fitted a newer high flow rad fan just bled all the air out and the top hose let go so need to get another one it was a bit manky will do top hose and thermostat as it took forever to get up to temp.

 

image_zpscimtmrjk.jpeg

 

I also purchased a oil cooler setup for cheap so i set about mounting the cooler it still gets air where it is as there are holes in front of it and has some stone protection 

 

image_zpsrkiwr2cu.jpeg

 

 

having had lots of issues with these shit carbs and them being not the best for a rally engine (vac secondary hitachits ) there was not much point rebuilding them or spending any money at all on them. so ive purchased a lynx crossover single side draft manifold (the last one they had ) so im after a 45 dcoe or dhla and if i cant find one a 40 will do . As much as id like to go twins i cant find a manifold for one ive only seen 2 manifolds on the net and cant get hold of ether of them but this will likely be a massive improvement anyway so ill put some pics up of that when it lands here from aussie this week some time. 

Share this post


Link to post
Share on other sites

Yesterday was parts day my manifold arrived blizzo has sorted me out a 45mm dcoe that was on his kp so hopefully should have that next week when I get paid. This is the last one lynx had and I can't imagine them making any more for an obscure car now. 

 

IMG_0784_zpsjfou2gqj.jpg

  • Like 3

Share this post


Link to post
Share on other sites

so finally got all the bits i needed to put this bad boy together with the dcoe 45

 

image_zps2elxmftq.jpeg

 

while i had the inlet manifold off i put my oil filter sandwich plate on and replaced the plastic oil pressure gauge line with a copper one as the plastic one wasn't far from breaking 

image_zpsfnhzh6y1.jpeg

 

test fitted the new manifold only needed a small buzz with a flapper wheel for the base to clear the engine mount bracket 

image_zpsxkoyuszx.jpeg

 

whilst I had the manifold off i confirmed the head had infact been ported 

image_zps8bkypgnj.jpeg

 

picked up my dcoe 45 that I got from Blizzo that his workmate brought to wellington for me 

image_zpsnxfzb18v.jpeg

 

but repco dicked me on my gasket (long story ordered the right one and a nissan sump gasket showed up for me to collect ) so I had to wait till today to actually put it on. I also fitted a new rad top hose as my one had split and I got a few fittings to connect up the water lines as the sizes were different with the new manifold 

 

image_zpszi5unxbe.jpeg

image_zpsivu3o2v8.jpeg

image_zpsgqja1xrw.jpeg

 

as you can see its a tight sqeeze not alot of firewall clearance once the filter is on oh also 

 

 

 

its alive runs ok need to get some linkage setup and a actual throttle wheel that i can adjust the idle on not something i cobbled together to get it running 

 

http://vid553.photobucket.com/albums/jj394/jake19904/Mobile%20Uploads/trim.C99496A5-5FF9-4A00-A3C9-86B03983DAFA_zpslqojxnux.mp4

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this