Tyla

Tyla's Toyota mr2 aw11 3sgte

Recommended Posts

3sgte swapped aw11 just passed certification I'll post some photos of when I was doing the motor swap and where I'm up to now

  • Like 3

Share this post


Link to post
Share on other sites

Sideby side with the 3sgte and e153 transmission, everything is much wider but length is about the same which is good as I was worried about it fitting between the "chassis" rails

Snapchat-1189315008.jpg

Share this post


Link to post
Share on other sites

Motor in positioned and mounts (4 of them) welded up out of 5mm plate, only a few wires to hook up and it will be all done...

Screenshot_20180306-201419.png

  • Like 7

Share this post


Link to post
Share on other sites

So I jacked up the car to have look around and make sure everything was good as theres been a bit more rattling than normal lately and found that my front lower engine mount where it bolts into the chassis wasn't happy about the extra torque so it looks like I'm going to have to get some more practice welding

IMG_20180313_155332.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Having a closer look it looks like one of bolts rattled loose and the other one got ripped out

IMG_20180313_162113.jpg

Share this post


Link to post
Share on other sites

Fixed by welding a piece of 5mm plate with a nut welded to the back of it hopefully it wont rip out again when I start turning the boost up

IMG_20180317_132205.jpg

  • Like 7

Share this post


Link to post
Share on other sites

Quick drive today doing a bit of "testing".

Cars running really well but suspect I have broken the front lower engine mount again, will investigate later

Screenshot_20180330-171604.png

Share this post


Link to post
Share on other sites

Re did the exhaust on the mr2 today to make it breath better, all 3inch piping with the smallest bit being 2.5inch at the flex joint.

Kept the cost down by getting all the tubing and muffler from a wreckers.

It's a fair bit louder but is pulling harder and all the way to redline which the old 1.75inch (at the tightest point) exhaust was restricting

Screenshot_20180512-193800.png

  • Like 2

Share this post


Link to post
Share on other sites

been having trouble getting the car to boost properly and am starting to run out of ideas so i logged some pulls and was surprised to find the car was making 16psi momentarily in first gear and then about 10psi in second and 9psi in third and taking quite awhile to spool.

if anyone has any ideas they'd be much appreciated

 

1.PNG

2.PNG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.