Firebrand

Firebrand's 1983 Mitsubishi Starion

11 posts in this topic

I've owned my 1983 Starion GSR-II for almost 5 years now. 

 

This is taken earlier this year: 

DSCF0193Medium.jpg

 

Bought it sight-unseen from Christchurch and drove it back to Wellington. 

I moved to Dunedin in 2010, so drove it all the way down packed full of gear. 

Spent the next three years tinkering with it and driving it all around Otago, it was pretty solid and reliable considering 80's, turbo etc. but the paint was flaking badly in places (from a poor respray sometime in the distant past), heaps of play in the steering and it was getting a bit of rust in sills, doors etc.

 

So at the start of 2013, I returned home to Wellington, got a better job and the last couple of months I am finally starting to make some progress on the car. I hauled it into my garage and went over it with a fine toothed comb, noting down every flaw to be fixed and improvement to be made. I ended up with a list of around 160 items! The major ones are a repaint (properly this time),new wheels (probably 15" this time), getting steering sorted, LSD (if I can find one), and just a really good tidy up of everything else. 

 

So the tear-down begins :

 

WP_20131020_008_2.jpg

 

Found a bit of rust so far (mostly in the rear corners), but not as bad as I expected. Paint is flaking off all over the place, it looks way better in the photo than in real life.

 

Pulled off the fenders:

WP_20131215_003b.jpg

 

I think I've saved about 2kg in weight just from dirt and dust I've removed from underneath panels and other places. Luckily very little rust on either fender, which I am really happy about, as starions usually rust like crazy there. Underneath the fenders looks pretty good too. Just needs a cleanup and a coat of paint.

 

WP_20131215_008b.jpg

 

The door in the background of the second photo is rust free and almost ready to go on the car also.

 


4 people like this

Share this post


Link to post
Share on other sites

So I've been making slow but steady progress, new door is on, rust free and straighter than the previous one. I've repaired both front fenders. Pulled off all intercooler piping, repainted everything and replaced all silicon joiners. New spark plugs & leads, gave engine bay a general tidy up. Replaced the gear shift bushing & changed trans fluid, gearbox feels much tighter now. There's so much more stuff I've forgotten about, but it's getting there.

 

I fixed up a whole lot of surface rust and flaking paint around the rear of the car. 

 

I've decided against getting a full repaint for now, I don't have enough money at the moment, and I really want to just get the car back on the road. 

 

So today, I put in a new battery, and fired her up for the first time in 6 months, started fine without too much complaining :) 

 

DSCF0816.jpg

 

Just need a bit more paint work, mostly in the rear lower fenders, then to reassemble everything. Once ready I'll book it in for a WOF, also needs new tie rod ends (and probably more), and the clutch is engaging with the pedal really close to the floor so I'll get that checked out too. 

 

All going to plan it should be ready by the end of May (famous last words!)

DSCF0815.jpg

Share this post


Link to post
Share on other sites

Almost back in business. I put on the late model (Widebody) tail lights I imported from japan a couple of years back. Still haven't fixed the dented rear corner properly, but I don't care right now, I just want to drive it...DSCF0879Custom.jpg

 

Just a bit more reassembly to do, then in for a WOF, hopefully no major work needed...

 

Also picked up these nice old Clarion speakers (used but still in original box). I only got two, but I have 4 speaker holes to fill, so if anybody has a matching pair let me know:

 

DSCF0880Custom.jpg

1 person likes this

Share this post


Link to post
Share on other sites

A few weeks back I ended up buying a complete black interior from a guy in Auckland, I was heading up there for work anyway so it worked out well. My current interior was looking rather tired, so it's definitely an improvement. Over the last couple of weeks I've stripped out most of the old interior and put the new stuff in, not quite finished yet but it's looking good so far:

 

DSCF1021Custom.jpg

DSCF1027Custom.jpg

Best thing is the door cards have survived nearly 30 years without someone cutting speaker holes in them:

DSCF1023Custom.jpg

I haven't had time to get the dash swapped over yet, I think it's going to be a mission, but will be worth it, the new one is mint:

DSCF1026.jpg

 

So just a bit more stuff to do, then time to book it in for a WOF and see what's wrong with it...

4 people like this

Share this post


Link to post
Share on other sites

Went for a WOF today, got a bit of a list to work through but nothing unexpected:

 

post-7481-0-26529100-1414492114_thumb.jpg

 

I'm going to need a set of rear struts if anyone has any, as well as a Wiper motor and linkages.

 

Most of the other bits should be OK. 

Share this post


Link to post
Share on other sites
Finally some progress! The starion has a WOF & Rego. I'm picking it up from the garage tomorrow afternoon, and will be able to drive it legally for the first time in 2 years, it's so sad that it has taken me this long.

 

In October last year, I took it in for a WOF inspection, hoping to get it fixed up in time for summer. The list of failed items is in my previous post.

 

 

The garage replaced the worn steering bits, while I went on a bit of a shopping spree:

 

New rear shocks from Mookeeh in the US

Tokico front inserts from Amazon.com

New rear brake disks, pads and wheel bearings from Ebay

Sway bar bushings (SuperPro)

 

I wasn't 100% sure that the struts would fit, but the rear ones matched up perfectly, slightly shorter to match my springs also:

DSCF1045%20Medium.jpg

DSCF1048%20Medium.jpg

DSCF1049%20Medium.jpg

 

The front ones however caused all kinds of drama. I pulled out one of the old oil shocks, and test fitted a new insert. It fitted the strut, but the gland nut was the wrong size.

 

The factory gland nuts were far too thick for the new inserts.

 

I checked with autolign and they confirmed that the shocks were the right kind, but I tested with another pair of struts (thanks to oldschool mamber 'dave' from Whangarei), and finally saw the error - one of the tokicos had the correct nut, and the other (which I had been test fitting with) was too small.

 

After some trial and error autolign came through with a KYB gland nut that would fit the strut, it just needed a spacer to fit the top of the insert. So I got out my grinder & hand files and 'machined' a spacer from the not-fitting nut, which slotted in perfectly for a nice tight fit (here's a shot halfway through - once it was the right diameter I sliced off the plate at the top and ground down to fit, measuring as I went to keep it all flat and smooth):

IMG_20150516_140812417.jpg

 

And then installed the inserts:

IMG_20150419_170900032_HDR.jpg

 

By now I had moved house and given up on the orginal garage. I rebooked with another place nearer my current house for a new inspection.

 

They said the rear bearings and brake discs didn't need replacing after all, so now I have a spare set of each for the future.

 

All that was needed now was:

 

New clutch master & slave cylinder

New drivers side seatbelt

Power steering hose remanufactured and reinstalled as it was leaking, and my spare one leaked even worse.

 

Those are now all  sorted, and we are ready to go, can't wait for tomorrow :)

4 people like this

Share this post


Link to post
Share on other sites
So a word of warning, remember to close your bonnet when you leave the house!

 

Otherwise this happens:

 

IMG_20160715_080055875_small.jpg

 

IMG_20160715_080341785_small.jpg

 

IMG_20160715_080242406_small.jpg

 

Scary as shit when it flies up, had to steer off onto the shoulder of the motorway blind. Felt like a right muppet. I was working on it the night before and just left the bonnet resting closed without latching it on, then got up for work, backed out half asleep without noticing it wasn't properly latched. 

 

Surprisingly little damage, the bonnet is fine, and it couldn't get anywhere near the windscreen. The cowling is pretty fucked, you can see in the top photo where the bonnet struts have sheared through the metal. Bonnet has moved back a few cm, I can only just get it latched closed now. This weekend, I'll be pulling the front of the car apart again to see what I can do to fix it. 

 

Another couple of dents for the collection.

2 people like this

Share this post


Link to post
Share on other sites

Update time for this guy also. A while after the bonnet incident above, I got down to fixing things. I had to remove all panels etc from the windscreen forward, and ended up with something like this on each side:

IMG_20160811_203555530_HDR (Medium).jpg

I'm no panel beater, but I bashed it out as best as I could and used a bit of filler to smooth things out, first time I've done a decent panel repair like this and it took ages to get things looking nice. Here's how it came out - not perfect but not too bad:

IMG_20160922_211952220 (Medium).jpg

Threw on some paint from a colour matched spraycan, and polished the shit out of it until it looked half-decent. I have a replacement cowling in my stash so if I ever get the car repainted I'll probably replace this whole section with the fresh one anyway:

IMG_20161027_221312351 (Medium).jpg

Also had to straighten up the bonnet hinges, then put everything back together. Then I got a fresh one of these ready for summer cruising:IMG_20161217_164249003 (Medium).jpg

And I also picked up a set of these factory alloys which I may or may not put on, they look pretty decent though, but need a tidy up:P1040325 (Medium).JPG

 

 

 

4 people like this

Share this post


Link to post
Share on other sites

I've been having some issues with overheating under load for a little while now, to the point that I couldn't really drive up any hills or drive under boost. A bit of amateur diagnosis pointed to the issue being a blocked/dead radiator. I'm not surprised, as my current one was put in from a parts car I had six years ago, and it wasn't really in great condition back then. On top of that my fan clutch is totally stuffed.

So the only options I had were a second hand radiator off trademe  (which was likely to be just as shit as the current one), importing a new radiator and fan clutch from rockauto with no guarantee of quality, or for a similar price, getting a new aluminium radiator & electric fan. So the last option is what I did. 

It also allowed me to removed the rather sorry clutch fan, saving a bit of drag on the engine, and freeing up some space:592a85e7e433e_P1020334(Medium).JPG.b257b0d2f315fd1c4e83ee12a9e0c2cc.JPG

I installed the new radiator (it is designed for Nissan S13 Silvia with SR20) , with a little assistance from @ProZac's build thread:

It needed a custom bottom bracket which I made from a piece of 90 degree aluminium bar, it's functional  and solid, but it looks like crap (I'm terrible at metalwork) so I'll probably redo it sometime. I still need to make some proper top brackets, the current one is just temporary.592a85e7262f9_P1020333(Medium).JPG.c9b7a0c24c84a90f86a15ca6bd46959f.JPG

The top radiator hose is from an 89-90 Pajero v6, which fits pretty well. For the bottom hose, I used a bend cut off a P11 primera hose that had lying around, which is attached to the (shortened) factory hose with a length of 35mm OD aluminium tube. I flared the ends a bit to stop the hoses coming off:592a85e89a479_P1020337(Medium).JPG.3d26c6f49aef349a58af9adec3a22474.JPG

The fan is controlled by a Flex-a-lite fan controller via a relay, but the radiator actually has a bung for a screw-in temp switch (the seller said it didn't), so I'll probably swap it out at some stage as it has an ugly probe which fits in the radiator fins, so it looks pretty messy.592a85ea124c7_P1020338(Medium).JPG.fd8ada9ef0cff9739340620cab636f34.JPG

I got it all together and took it for a bit of a test drive tonight, all is working well so far, temperature was stable when driving or idling, and I also took it right to the top of the hill I live on, which is a pretty decent climb and no dramas at all. The fan switches on nicely and pulls quite a lot of air through. So now I just need to do those top brackets and tidy the wiring up a bit :) 

 

3 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now