Jump to content

ThePog implements mad boost on the Dynafari


Recommended Posts

  • Replies 574
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

1 hour ago, yetchh said:

Can't be any worse than a zephyr manifold... 

I thought I would look up what a zephyr manifold looks like, and yes it is definitely no worse than that. In fact I believe mine to be superior in a number of ways. I suspect I would have been an engineering visionary had I worked in the British car industry in it's heyday, all I would need to do would be to sit in the design meetings and suggest that maybe we shouldn't do this in the most retarded way possible.

  • Like 2
  • Haha 4
Link to post
Share on other sites

Anecdotally I read somewhere that they made the exhaust manifold like that so it didn't have too much power for the time.. If that's true my guess would be the skinny little 165/13s rolled over and died when power was applied out of corners..... 

  • Like 1
  • Haha 1
Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

I've been chasing a power steering pump leak which was the result of a bodge to the inlet I had done, I made a very beautiful replacement.

Then the ps pump appeared to shit itself immediately and I am a bit puzzled. I have stripped the pump down which seemed to be ok, some minor wear, and replaced the fluid when I put it all back together.

Now it works but only when the revs are up, there is almost no assist when at idle.

It is a bit weird and I kind of want to check the actual pressures but this might be a mission.

Any ideas on what to check?

I sort of remember a tech article on here about honing that shit up but I can't find it now.

Also it stopped charging, fucking thing is manufacturing things for me to do during lockdown...

 

  • Like 1
Link to post
Share on other sites
1 hour ago, Mof said:

That's it, I found it this morning after refining my search terms. I don't have a stone big enough unfortunately, but I just found another pump at the wreckers. If I can sort this I will be able to carry on testing over the next week's..

  • Like 1
Link to post
Share on other sites

 

54 minutes ago, Transom said:

Sheet of glass and fine sandpaper ? Or just sheet of glass and grinding paste ? 

I have some 1200  and 1600 grit paper, if I get stuck I'm sure I can use those.

I'll see how the new pump goes.

Link to post
Share on other sites
1 hour ago, mjrstar said:

No charge and weak power steer, not something as simple as drive belt slippage? 

Na I've been through all that, it had new belts anyway, checked those, degreased the pulleys in case they had got oil on there. Also I just checked the alternator output at the fuse box and there is nothing. I might have knocked something loose when I last had the engine cover off, so I will check that next.

The new pump spins way more freely than the old, I'll get it in there in the next couple of days.

It also appears to be running out of fuel around 3000rpm, I had the cover off to turn up the fuel, that test run got me 3600 revs and a bit more punch, but that run was also when the pump lost its shit.

Link to post
Share on other sites

The new power steering pump solved that issue, all is well now.

I then stripped the alternator down, it is in pretty poor condition, it was full of oily gunk that had been pushed through from the vac pump. The brushes were toast, pretty obvious that was the issue. If I can find some brushes it will do for a wee while, but this is proving difficult.

I may have to dismantle some power tools and whittle whatever brushes I find to suit...

  • Like 4
Link to post
Share on other sites

Ha, after all that it turns out the reg is fucked, the old girl pumps out 34v when spun up, probably unsuitable for battery charging.

Ah well.

Also the fucking power steering still isn't playing the game, it's fine for a wee bit but then loses it's shit. I am working on the theory that the pressure relief valve is sticking open.

Does anyone know if the valve is in the steering box or the pump?

Just as well I have time to look at this shit, but it's getting tiresome...

  • Like 1
  • Sad 1
Link to post
Share on other sites

Not too much help to you, but the one in my Saginaw box, was about the size of a hearing aid battery, on the Inlet side. 

I got it out with a pick/screwdriver. 

My power steer guy bored the pump out, and removed the relief valve - as mine was stopping flow going in - due to the AN fitting crushing it effectively closed. He mentioned they're more for when the box is higher up, to stop flow going back. Bit I figure its only a problem if the car isn't running.. 

Make sure you bleed the box with no load, full lock to lock (best to remove the pitman arm) - as full lock on the steering system may not be full lock on the box itself..

Link to post
Share on other sites

I dick around with it, fill it up, bleed it. Everything seems tickety boo then when I drive it, it drops to nothing. Sometimes increasing the revs makes it work again, but only at higher revs.

I checked the relief valve today, it moves freely, plus it was the same situation with the old pump, I wasn't sure if the valve was in the pump or the box, it's in the pump so that's not it. The problems started when I made the new inlet from the remote reservoir, maybe it is restricting the flow somehow, although I took some care to make sure it was as open as possible. Before this it was absolutely fine, although leaky.

Today I also decided to eliminate this as a possible problem and re jigged everything to work with the original reservoir that sits on top of the pump. This just means I have to make a hatch to access the filler from behind the drivers seat. This is nearly all done, I will check it tomorrow, if it's still bollocks then there must be a problem with the steering box...

Link to post
Share on other sites
  • ThePog changed the title to ThePog implements mad boost on the Dynafari

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...