Sign in to follow this  
kicker

Kicker's C50

Recommended Posts

50 minutes ago, kicker said:

Have cut the springs but not shortened the shock shaft so they are a wee bit (massively) uncaptive on droop.
I saw a dude on instagram shorten his by running the shaft thread down further then lopping the end off so thought I'd give the same a go.
I assume these would be hard chromed so grinding that off first would make it easier?

Also done the cutting shaft / thread etc. Didn't consider it being hardened just sent a die down it haha. Works well, need to do it to my Yamaha now. It has the massive droop from just cut springs - so many fingers caught under the guard when lifting the bike onto the trailer haha. 

  • Like 2

Share this post


Link to post
Share on other sites

Choice, cheers chaps, that'll be the go then.
I need to get my vice setup so I can do it and a few other jobs.

 

Share this post


Link to post
Share on other sites

What kinda tail lamp are you running on that trimmed mount? 

Its a problem for me. I havent found anything that mounts tidy to a trimmed mount and lasts :(

Share this post


Link to post
Share on other sites

Gonna use this guy

Pv9i8sD.jpg

The fist part is a similar size to what is left of the mount, gonna weld a plate in there and tap some holes to screw the light to, might even use some glue as the screws are pretty small, m3/4 I think.

What kinda trouble are your lights having?

  • Like 4

Share this post


Link to post
Share on other sites

cams 125 / my 140 /  pretty much any of the penny pinches 110s seem to vibrate the fuck out of any tight real bad. cam has even tried good narva lights to no avail. i think the best bet is LED although ive had issues with a few of them too. rubber isolators are the go i reckon. China engines although go well and are relatively reliable all seem to have some real weird harmonics / vibrations. cams 125 seems worse than most, and the batch of 110s we got.

probs doesnt help he ran it on shipping oil for like the first 500kms  

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

Running ballast resistors in them @BLIZZO?

My 140 was doing bulbs just about every ride until I added one.

Share this post


Link to post
Share on other sites

My tail light is LED funnily enough, I guess because of the unusual shape also have a TrailTech already on its way, wish I'd seen @My name is Russell post about selling some, been waiting 4 weeks now haha

Share this post


Link to post
Share on other sites

Yeah Trailtech the world. Im running a Ali X round led tallight and some unknown rectangular headlight with a 12v bulb and my trailtech has kept those bad boys strumming hard for a solid 2500km now. Even with all the engine vibrations and what not. Running 4 trailtechs on 4 bikes and have yet to have a issue with lighting  

  • Like 1

Share this post


Link to post
Share on other sites

I prefer the standard reg/rect set up personally, I like having indicators and horn etc running from the battery circuit.

  • Like 1

Share this post


Link to post
Share on other sites

The Skyteam ace I built has all of those and no battery and also runs a trailtech with no issue.

Ya'll need to on the train before it leaves ya behind

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
17 hours ago, Chris.QCR said:

The Skyteam ace I built has all of those and no battery and also runs a trailtech with no issue.

Ya'll need to on the train before it leaves ya behind

this is what i want in my life, i have a trailtech on the shelf waiting to go in my CB50, how  do you run the indicators etc, just run them on AC and they are fine?

Share this post


Link to post
Share on other sites

My 125 doesnt vibrate that bad. Only as bad as any other 125/140 ive experienced.  Nothing like the 110s.  Dont think shipping oil did it any harm jim . doesnt burn drop of oil. Have seen some fairly smokey lifans from guys who did shit the 'right way'.

Was using hella lights and the blub holders were falling to bits fairly quickly.

Will try some rubber isolators. 

Share this post


Link to post
Share on other sites

My 125 vibrates like fuck and I love it. I do skids and/or ride WOT till oil empties out the breather but I keep it topped up and then change it out every 1000kms or couple of months - whichever comes first. Shipping oil is shit. Don’t use it; regardless if it didn’t harm anyone else’s bike. People will probably still debate this though because it was ‘fine’ for them. 

Anyone ever been to a Lifan factory? I have. The quality control isn’t great; but the products generally are epic and last well as long as they’re ‘looked after’. Generally this means every single person has a different experience with every engine made.

Ed March has done over 100,000 miles on Lifans; but he maintains them religiously and strips them down before use and triple checks tolerances and torque on bolts etc. Don’t really need to go that nuts unless you’re riding around the world. 

TLDR; everyone will experience different things in different ways. 

Anyway; sick bike. Loving the tail light and the full rear fender. Can’t wait to see this thing hooning!

Share this post


Link to post
Share on other sites

Another shit update. I bought one of those $9.50 pit bike exhausts for something to start with.
It fit ok as it was but had a lot of angles going on so I cut and rotated the header a few degrees to bring it closer to the engine and make it more horizontal, then cut off the bent up section on the end, flipped it around and welded it on straight then cut a slash to tidy up the old bend.
Will weld some nuts on it to use the stock exhaust-swingarm bracket then that should do for now/forever

qsGw7H8.jpg

GOgpDmX.jpg

2Cn8vfG.jpg

  • Like 7

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this