felixx

Felixx's Ford Anglia 105e

60 posts in this topic

Picked up my wheens from Action Powder Coating in Hornby.

Conrad is an all round GC. They have been ready for a bit, I have just been too busy/ lazy to get them.

Pretty happy with the finish. The rims had some rust so there is some pitting on 2 of them although only one is bad.

$200 for sandblasting and coating.. good value!

P2020210.jpg

not heaps of dish, but enough for me!

P2020211.jpg

before and after

P2020208.jpg

A pic of the pitting, however I can live with this for now!

Share this post


Link to post
Share on other sites

New Rims went on today.

The guy at the tyre shop had some 'second hand khumos' that still had the moulding dimples for and stickers on them for $61 each, unfortunately he only had 2, but I had 2 decent ones anyway.

P2040223.jpg

P2040214.jpg

P2040220.jpg

I know she needs some dropping.. working on it, more info to come

Share this post


Link to post
Share on other sites

Hmmmm as you can see by my build thread July 1 2011 I fitted a new master cylinder to the brakes.

Fucking thing is leaking.

Back to BNT for a new one!

Wish I still had a reciept.

Edit: Went to BNT and got a new one. Is it worth getting them to send the other one back to their supplier (6 1/2 months old, 1200 miles old?

Share this post


Link to post
Share on other sites

I put a new master cylinder in and bled up brakes. Car stops good now. Real good.

Decided not to take old (new) cylinder back as it may have been damaged in the engine fire (was scorching on it).

Rolling oldschool - it is awesome

Share this post


Link to post
Share on other sites

Another pictureless post but I got the outer tie rod end on the port side tonight, thats both outer ones done, should I have done the inners at the same time?

Share this post


Link to post
Share on other sites

tried to upload a pic but pc is fucked for now

Share this post


Link to post
Share on other sites

car has 4 new tie rod ends.. this has made a huge difference

Share this post


Link to post
Share on other sites

OK So I made up a jobs list a wee while back.

As you can see, things are not happening in any special order, but they are happening

carlist-1.jpg

Edit:

I have the exhaust, just need a set of pre crossflow xtractors (this is because one day I plan to put a 1500 cortina motor in there, but not for a wee while)

to explain things further - the rear shock conversion means to turn the armstrong levers into telescopics

roll bar upgrade, bolting a 2nd roll bar to the first (looks BAWS)

the rest makes perfect sense I reckon)

Super Edit:

I removed the parcel tray and heater today to re-replace the heater motor.

It turns out it was an Earthing problem. I have installed a 2nd (back up) earth to the heater and the whole lot goes back in tomorrow. I am relieved.

Thanks for reading this.

Share this post


Link to post
Share on other sites

Well after 8 hours I got my big zorst on.

No extractors as they fell thru, the guy in kaiapoi was a knob who sells them but doesnt allow pickups.

I told him a lie and said I had got some elsewhere.

Usual story about measure twice - cut once.

today we measured 4 times, cut n welded thrice

However in the end I learnt a bit about welding

And car sounds happy

Got to use my new headlights on the way home (2 things off list)

Share this post


Link to post
Share on other sites

Pictureless update..

Installed a tacho today.

Will post pics when I can be bothered going outside

Share this post


Link to post
Share on other sites

175/70s = 4000 rpm at 60mph

New tyres, rpm measured on my new tacho

Share this post


Link to post
Share on other sites

Got some gauges in her:

guages.jpg

oil, voltage, vacuum and tacho

Share this post


Link to post
Share on other sites

Sat night I noticed my heater fan had stopped running AGAIN! - Last time I put a 2nd earth on it to stop it happening

So monday night I removed my gauges, parcel tray and heater. Tested heater on battery.. it worked fine, however there was a fine layer of coolant in the heater box...so maybe there is a tiny leak in the matrix.. explaining why the demister puts a thin layer of mist on the windows..

Anyway i rewired the heater and re assembled the interior

All appears to be sweet.

I have an exhaust leak where the 'zorst meets the manifold. Im guessing that the maniseal is too rigid so I tried some red high heat silicon.. it appears to be holding up nicely.

Will do for now

Share this post


Link to post
Share on other sites

OK so spring/ summer is coming and I need to paint my Anglia..

I plan to use the original blue, however I am unsure whether to paint it:

the original all blue paint like this:

anglia1.jpg

or with a white roof and swage line like this:

CR025.jpg

or blue with just the white roof

What do you folks think?

Share this post


Link to post
Share on other sites

was driving my car pool and zorst was scraping on road

(never used to do this)

I checked my rear shock levels (armstrong shocks).

The RH One was dry...

Topped them up with motorcycle fork oil.

Share this post


Link to post
Share on other sites

Picked up some 4-2-1 extractors for my car today (2nd hand but seem pretty good)

will post pics tomorrow

Just need to get someone to fit them.

Share this post


Link to post
Share on other sites

Long time no posts about angrybox

my wife and I had our 2nd child november 2012.

with beka not working anglia got put on back burner, however I got her out tonight,

she runs good, although vacuum guage is all over the place, maybe tappets need adjustment or a valve is tired?

I installed an electric window washer so I dont have to pump the window washer as I drive

tidied up rear exhaust mount for wof

about to regrease rumbly but new wheel bearing then pack ball joints with grease to try for wof tomorrow.

I know I need to rebuild the ball joints but thats more cash than beka will let me have for the car this week

Share this post


Link to post
Share on other sites

Well an update is due,

wof time today

L and R wheel bearings noisy

rust in rear lh lower sill

exhaust mountings

rh rear suspension leak,

ball joints worn

also he thinks the rear diff bearings are noisy

L F shock leaking slightly

rr susp slight leak

hmmmmm

no wof for all ford day.

Bugger

Share this post


Link to post
Share on other sites

Big breakthru today, the automotive students are building my 1500 pre x flow for me at school this year!

7 people like this

Share this post


Link to post
Share on other sites

So I have this for a while now.

It failed a WOF quit badly.

So first off the exhaust was in a shit state, not mounted well, leaking, just nasty.

we've fitted some headers and I added a GT intake Felix had kicking about. There was no GT carb though so I've made an adaptor to fit the original carb.

It seems to work ok.

Anglia001_zps769b8c91.jpg

Anglia002_zps27e63147.jpg

Next up. Ball joints, wheel bearings, and rust.

6 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now