kws

Kelvin's 1985 Rover SD1 Vanden Plas EFI

62 posts in this topic

Sigh. This car must have the cleanest coolant of any car – ever.

I replaced the water pump today. The old one started leaking from the weep hole, indicating that an internal seal had failed.

I’m not overly sad about having to replace it. Someone badly painted it black at some point and it was bloody ugly. It wasnt in good shape anyway.

Since the car was already in the garage overnight, the first step was to drop the coolant. Again. It seems like this car gets new coolant every month or so.
DSC09566.jpg?resize=1024%2C681

I caught most of it this time, with minimal spillage. Wish they had added a drain plug to the radiator when they reconditioned it. Yes that’s coolant on the grille and valance…. 
DSC09565.jpg?resize=1024%2C681

The coils had to be moved out of the way so I could take the tension off the alt belt to remove it. Thankfully someone smart built the coil bracket and it moves out of the way easily with only two bolts. The fan was also removed.
DSC09570.jpg?resize=1024%2C681

Then it was a matter of undoing all the bolts, and removing the pump. Thankfully someone in the past had used grease and copper grease on all the bolts, and all of them came out ok, not a single one broke. Guess I don’t need the Ez-Out set that I purchased last night.

It wasnt a pretty sight. Badly painted
DSC09578.jpg?resize=1024%2C681

The reason im replacing it. The weep hole.
DSC09575.jpg?resize=1024%2C681

Looks like it was an original Leyland part. Maybe it was rebuilt years ago?
DSC09579.jpg?resize=1024%2C681DSC09580.jpg?resize=681%2C1024

This hose outlet has been weeping since I got the car. Even with the brand new hoses. This is why, it’s got a horrific buildup on it. I tried to wire brush some of this off last time I had the hose off, and got no where.
DSC09573.jpg?resize=1024%2C681

The insides don’t look much better. Some weird crusty stuff inside it
DSC09571.jpg?resize=1024%2C681DSC09572.jpg?resize=1024%2C681

And compared to the new pump
DSC09589.jpg?resize=1024%2C681

The new pump is much nicer to look at, and it spins smoother too, so maybe the bearings on the old one were starting to go.
DSC09585.jpg?resize=1024%2C681DSC09586.jpg?resize=1024%2C681

The replacement pump has a shorter snout than the old one, so the fan will sit slightly further away from the radiator
DSC09587.jpg?resize=1024%2C681

The front cover of the engine looked pretty good. No buildup and only slight discolouration.
DSC09582.jpg?resize=1024%2C681DSC09583.jpg?resize=1024%2C681

I swapped over the pulley, with all new bolts and washers
DSC09590.jpg?resize=1024%2C681

And then a fail. I forgot to fit this bolt, and it wont go through the hole with the pulley on. Oops
DSC09592.jpg?resize=1024%2C681

These are the PN for the pulley bolts and washers. 3x each
DSC09591.jpg?resize=1024%2C681

So I didn’t lose track of where the bolts go (even though in the end it didn’t matter as its pretty obvious), I traced the pump onto some paper and laid the bolts out as I removed them
DSC09593.jpg?resize=1024%2C681

Water pump came with a new gasket, which I fitted with a thin smear of sealant on each side
DSC09594.jpg?resize=1024%2C681

Now this is where it gets annoying. I ordered all the bolts as per the parts guide, and even though I ordered more than the quantity needed, I still didn’t have everything I needed. Maybe I mucked up, who knows.

I needed 5x BH505441, which are the really long bolts
DSC09598.jpg?resize=1024%2C681

Somehow I ended up with 2x slightly shorter bolts too, which were useless. I needed 5x SH504091, the shorter bolts
DSC09599.jpg?resize=1024%2C681

I also needed standard flat washers for each short bolt, which somehow I completely missed. This wasn’t an issue as I ended up just reusing all the washers as they were in good shape. A couple of the long bolts have weird, really thick washers too, which don’t show in the parts guide.

There was one bolt at the top of the water pump which is a different size to all the others. Its short, but 5/16″. I think it might be 254020 in the guide, but Rimmers doesn’t list it. I reused mine, but you would be buggered if you broke it off.

The newly fitted pump looks awesome. So much nicer.
DSC09600.jpg?resize=1024%2C681DSC09601.jpg?resize=1024%2C681

With the shorter snout I chose to try the “correct” fan, that wouldn’t fit with the other pump.
DSC09602.jpg?resize=1024%2C681DSC09603.jpg?resize=1024%2C681

Looks good, but dammit, the bloody thing has a stuffed clutch. Locks when cold. So I had to swap back to the other one, which I will now stay with. I can trust and rely on it. Its a bit colder than I would like to run, but i have set the Speeduino up to compensate. I’ll change to an electric fan at some point anyway.

Since the coolant was out again, I chose now to loop the coolant lines for the throttle body. I don’t need the coolant “hot spot” anymore. Apparently its there to stop the throttle plate freezing over, but there are other theories about it helping fuel atomization when cold too. Either way, I’ll let Speeduino do what it needs to do, without warm air being added in after the IAT. It was easy to do, remove one hose, and loop the other into the inlet manifold.

DSC09608
DSC09609
DSC09610
DSC09611

Also, since I found the source of the intake drone, I refitted the air inlet trumpet
DSC09613.jpg?resize=1024%2C681

All buttoned back up and ready to go
DSC09614.jpg?resize=1024%2C681

I finally got to drive the car again, to bleed the system and get it up to temp. God its good to drive this car, I love it. The last tune we did was really good, it pulls like a freight train and drives very smooth.

System bled OK, heater is hot, and coolant temp is stable. Its holding all its coolant for the most part. I noticed that the long bolt that goes into a coolant gallery is weeping, so I’ll need to get some sealant on that one.
DSC09612.jpg?resize=1024%2C681

I did find come up against the infamous Rover SD1 engine ground issue though. When trying to start the car, it would act like it had a flat battery, despite it being a new battery and even adding a jump pack to it. I remembered hearing about another SD1 owner that had a grounding issue and mentioned that their throttle cable ended up being the main engine ground and melted.

Sure enough, the cable was warm to the touch. Dammit, the main cable was attached, on both ends, and obviously still wasn’t good. Back when I fitted the coil bracket, I moved the ground strap to one of the bolts on the alternator bracket, and it was working fine. I loosened it off, gave it a wiggle, did it up again, and bam, the car started. Guess I’ll need to look at that at some point, maybe even add another ground just in case. Oh well, its working again now. Typical Rover.

Oh, and just as a little teaser…
DSC09607.jpg?resize=1024%2C681

2 people like this

Share this post


Link to post
Share on other sites

Finally, another thing that’s been bothering me, fixed.

I started prepping the washer bottle the other day, and today I finished it.

My painting skills leave a lot to be desired, but its a whole lot better than it was. The rust converter left a fairly rough surface, even after some prep work, maybe the metal was pitted?

The new strap from the club fits and looks great.
DSC09617.jpg?resize=1024%2C681DSC09618.jpg?resize=1024%2C681DSC09619.jpg?resize=1024%2C681DSC09620.jpg?resize=1024%2C681

Bit of a difference?
DSC09557.jpg?resize=1024%2C681DSC09617.jpg?resize=1024%2C681

I forgot to take a photo of the new brass radiator fill plug I fitted, so here it is

From this old plastic one that always felt like it was going to cross thread and strip when fitting
DSC09569.jpg?resize=1024%2C681

To a nice brass one which screws in smooth as butter
DSC09616.jpg?resize=1024%2C681

These stickers came in the other day, so one went on the car.
DSC09621.jpg?resize=1024%2C681

Jolly good.

3 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now